PriorityPBX Degraded Service
Resolved
May 01 at 02:16pm AEST
Incident Post-Mortem: DDoS Attack
Overview
We recently experienced a significant outage caused by a sophisticated Distributed Denial-of-Service (DDoS) attack targeting our upstream phone infrastructure carrier.
What is a DDoS Attack?
A Distributed Denial-of-Service (DDoS) attack is a malicious attempt to disrupt the normal traffic of a targeted service, network, or server by overwhelming it with excessive internet traffic from multiple sources.
Incident Details
Our upstream provider had multiple layers of DDoS prevention in place; however, the scale of this attack was unprecedented at approximately 1 terabit per second, overwhelming existing defenses.
Throughout the incident, our team maintained constant communication with our upstream carrier, coordinating closely to mitigate the disruption.
Historical Context
We have relied on this upstream carrier for 13 years with an exceptionally high uptime and virtually zero major disruptions, significantly outperforming typical carrier reliability, including major providers such as Telstra and Optus.
Mitigation and Improvements
In response to this incident, our upstream carrier has now implemented a more sophisticated and robust DDoS mitigation solution powered by Cloudflare. Cloudflare's advanced systems are capable of handling DDoS attacks up to 350 terabits per second, providing significant protection well beyond current known threat levels.
Nature of the Attack
The scale, sophistication, and coordination of the DDoS attack strongly suggest it was state-sponsored. This attack was highly complex and intended to cause significant disruption.
Conclusion
We appreciate our customers' patience and understanding during this unprecedented incident. Our infrastructure now benefits from industry-leading defenses, significantly enhancing our ability to prevent such disruptions in the future.
Affected services
Incoming Calls
Outgoing Calls
Faxing
Updated
Apr 30 at 02:18pm AEST
We are observing calls and portal access returning to normal.
Our upstream carrier has confirmed that the DDoS attack has ceased.
Some supplementary services, including phonebook and voicemail, remain offline but are expected to be restored shortly.
We will continue monitoring the situation closely and provide further updates as necessary.
Affected services
Incoming Calls
Outgoing Calls
Faxing
Updated
Apr 30 at 08:45am AEST
The ongoing DDoS attack targeting our upstream carrier has intensified, resulting in wider disruption affecting calls from off-net carriers. Phones powered by Aussie Broadband and Vonex internet connections remain largely unaffected at this time.
We continue to monitor this situation closely and will provide additional updates as they become available.
Affected services
Incoming Calls
Outgoing Calls
Faxing
Updated
Apr 29 at 01:33pm AEST
The DDOS attack remains prevalent for our upstream carrier.
Faxing, Address Books, SMS, Voicemail and web portal access continue to be affected.
Calling continues to be un-affected.
We will continue to update this entry as new information becomes available.
Affected services
Incoming Calls
Outgoing Calls
Helpdesk - Phone Support
Faxing
Updated
Apr 28 at 01:24pm AEST
Call services have resumed to normal operation. Issues with faxing and voicemail retrieval persist.
Affected services
Incoming Calls
Outgoing Calls
Helpdesk - Phone Support
Faxing
Updated
Apr 28 at 11:34am AEST
Connectivity issues have been restored for phone calls.
There are still ongoing issues with voicemails and some of the web portals.
We are continuing to monitor the situation.
Affected services
Incoming Calls
Outgoing Calls
Helpdesk - Phone Support
Updated
Apr 28 at 09:03am AEST
Incident Update:
The outage caused by a DDoS attack on our upstream provider is ongoing. We are actively working with our carrier, who has not yet provided an ETA for resolution.
Currently, voicemail services and web portals for PriorityPBX may also be impacted.
We will continue to monitor closely and provide further updates as soon as more information is available.
Affected services
Incoming Calls
Outgoing Calls
Helpdesk - Phone Support
Created
Apr 27 at 06:00pm AEST
We're currently experiencing a significant DDoS cyberattack targeting our phone infrastructure, causing connectivity issues for a small portion of customers.
Customers not using Aussie Broadband may experience disruptions. Over 95% of customers remain unaffected.
We're actively monitoring this incident and will provide updates as soon as possible.
Affected services
Incoming Calls
Outgoing Calls
Helpdesk - Phone Support